Location: PHPKode > projects > Xoopslance > xoops-2.0.16/release_notes.txt
XOOPS 2.0.16 release notes (2006/11/12)
------------------------------------------------------------------------------

The XOOPS development team is pleased to announce the release of XOOPS 2.0.16.

This is a maintenance release containing several bugfixes.

Read the full changelog for details.

System requirements
-----------------------------------
PHP
    Any PHP version >= 4.3 (PHP 4.2.x may work but is not officially supported)
MySQL
    MySQL server 3.23+
Web server
    Any server supporting the required PHP version (Apache highly recommended) 

Downloading XOOPS
-----------------------------------

Your can get this release package from the sourceforge.net file repository.
Both .zip and .tgz archives are provided.

Installing XOOPS
-----------------------------------

   1. Copy the content of the htdocs/ folder where it can be accessed by your server
   2. Ensure mainfile.php, cache, templates_c and uploads are writable by the webserver
   3. Access the folder where you installed the htdocs/ files using your web browser to launch the installation wizard

Upgrading from a previous version
-----------------------------------

Upgrading from XOOPS 2.0.14/2.0.15 (easy way)

   1. Get the appropriate update package from the sourceforge file repository
   2. Overwrite your existing files with the new ones
   3. Access <your.site.url>/upgrade/ with a browser
   4. Follow the instructions to update your database
   5. Delete the upgrade folder

Upgrading from XOOPS 2.0.14/2.0.15 (using the full package)
   1. Move the "upgrade" folder inside the "htdocs" folder (it's been kept out as it's not needed for full installs)
   2. Delete htdocs/mainfile.php, and htdocs/install
   3. Upload the content of the htdocs folder over your existing files
   4. Access <your.site.url>/upgrade/ with a browser
   5. Follow the instructions to update your database
   6. Delete the upgrade folder

Upgrading from any XOOPS ranging from 2.0.7 to 2.0.13.2 (using the full package):
   1. Move the "upgrade" folder inside the "htdocs" folder (it's been kept out as it's not needed for full installs)
   2. Delete htdocs/mainfile.php, and htdocs/install
   3. Upload the content of the htdocs folder over your existing files
   4. Delete the following folders and files from your server (they belong to an old version):
          * class/smarty/core
          * class/smarty/plugins/resource.db.php
   5. Empty the templates_c folder (except index.html)
   6. Ensure the server can write to mainfile.php
   7. Access <your.site.url>/upgrade/ using your browser, and follow the instructions
   8. Write-protect mainfile.php again
   9. Remove the upgrade folder after use
  10. Update the "system" module from the modules administration interface

Files integrity check

The full XOOPS package is now released with a script able to check if all the system files were correctly uploaded to the server. To use it, follow these instructions:

   1. Upload the xoops_md5.php and xoops.md5 files located in the XOOPS package root to your XOOPS server folder (putting them next to mainfile.php).
   2. Execute xoops_md5.php with your browser
   3. If necessary, re-upload the missing or corrupted system files
   4. Remove xoops_md5.php and xoops.md5 from your server

Revealing the blank page backtrace log

XOOPS displays a basic error page when a fatal error preventing it to run is encountered. To help you diagnose
the cause of the error, this page contains additional messages that are hidden by default. To reveal them, use
your browser "select all" function (for most browsers, you can use "Ctrl+A").

Unsupported templates access

It has come to our knowledge that some modules contain a hacked version of the XOOPS module installation routine and access the templates/blocks database tables directly, bypassing the regular templates declaration mechanisms. Because of this, some recent changes in the templates handling system made those modules unable to access their template data.
If you use one of these modules, you may fix this problem by replacing the resource.db.php file located in the class/smarty/xoops_plugins/ folder by the one provided in the package extras folder. Please note however that such bypassing of standard interfaces through the inclusion of hacked core parts is not supported and that those modules won't work with future versions.

Modules

The packages do not contain any module apart from the system one. You are invited to browse the XOOPS modules repository to get some.
Some of the best modules can be found in the following locations:

    * Herve Thouzard's site (News, mydownload, shortcuts... http://www.herve-thouzard.com/ )
    * Panther Software Publishing (xProject, xStreamer, xAsset http://xprojects.co.uk/ )
    * Smart Factory (SmartSection and many others http://www.smartfactory.ca/ )
    * XForge site (CBB forum, Wordpress, MediaWiki... http://www.xoopsforge.com/ )

We also highly recommend the installation of the Protector module which will bring additional protection and logging capabilities to your site.

Return current item: Xoopslance