Location: PHPKode > projects > XOOPS Spanish > release_notes-es.txt
El equipo de desaroollo de XOOPS se complace en anunciar la disponibilidad de la versión de XOOPS 2.4.4 Final.

Esta versión incluye correcciones con respecto a la versión 2.4.3

  

Requerimientos del sistema
-----------------------------------

PHP:
Cualquier versión de PHP >= 4.3 (PHP 4.2.x debería de funcionar pero no es oficialmente soportada, PHP 5.0+ es muy recomendable)

MySQL:
MySQL server 3.23+ (MySQL 5.0+ es muy recomendable)

Web server:
Cualquier servidor que soporte la versión requerida de PHP (Se recomienda Apache)


Descargar XOOPS
-----------------------------------

Puedes descargarlo desde el repositorio de sourceforge.net.
Ambos archivos .zip y .tgz están disponibles.


Instalando XOOPS
-----------------------------------

   1. Copiar el contenido de la carpeta htdocs/ a su servidor
   2. Cerciórese de que mainfile.php y uploads sean escribibles por el servidor
   3. Por razones de seguridad, le sugerimos que mueva la carpeta xoops_lib (la carpeta que contiene las bibliotecas de código para XOOPS) y xoops_data (para los datos de XOOPS) fuera de la raíz del sitio, o incluso cambiar los nombres de las carpetas.
   4. La carpeta xoops_data/ debe ser escribible; Crea y establezca permisos de escrituras a las siguientes carpetas: xoops_data/caches/, xoops_data/caches/xoops_cache/, xoops_data/caches/smarty_cache/ y xoops_data/caches/smarty_compile/
   5. Acceda a la carpeta donde copió los archivos necesarios para la instalación utilizando su navegador web. Inicie el asistente de instalación
   6. Seguir las instrucciones


Instalando Protector en XOOPS
-----------------------------------
Asimismo, recomendamos la instalación del módulo PROTECTOR que le aportará mayor seguridad a su sitio:


Actualizando desde una versión anterior
-----------------------------------

Actualizar desde XOOPS 2.3.x y 2.4.0 (modo fácil)
   1. Obtener el paquete de actualización correcto desde el repositorio de sourceforge
   2. Sobrescribir los archivos existentes con los nuevos
      * asegúrese de que copia el contenido de /xoops_lib a cualquier carpeta que tengas en el servidor (e.g. si lo desplazas fuera del directorio raíz). No podrá haber dos directorios con contenido de /xoops_lib
   3. Si tenía ya Protector instalado previamente, abra el archivo "mainfile.php" y elimine las siguientes líneas (en caso de que existieran):
   
      include XOOPS_TRUST_PATH.'/modules/protector/include/precheck.inc.php' ;
      include XOOPS_TRUST_PATH.'/modules/protector/include/postcheck.inc.php' ;
   
   4. Si está actualizando desde XOOPS 2.4.x, asigne permisos de escritura al archivo /include/license.php (permisos 0777 en Linux)
   5. Acceder a <su.sitio.web>/upgrade/ con el navegador, y siga las instrucciones
   6. Seguir las instrucciones de actualización de la base de datos
   7. Elimine la carpeta upgrade una vez actualizado
   8. Actualice el módulo "sistema" desde el administrador de módulos, y actualice los otros módulos, en especial el módulo "profile".


Actualizar desde XOOPS 2.0.* superior a 2.0.14 y 2.2.* (usando el paquete completo)
   0. Descomprima el archivo a su ordenador LOCAL (por ej. PC) en una carpeta temporal.
   1. Envía al servidor la carpeta "upgrade" incluida en "htdocs" de su disco duro (se mantiene fuera porque no es necesario para las instalaciones nuevas)
   2. Borre htdocs/mainfile.php, htdocs/install/, htdocs/cache/, htdocs/extras/, htdocs/template_c/, htdocs/themes/ y htdocs/uploads/ de la carpeta "htdocs" de su ordenador LOCAL
      * si ha creado la carpeta XOOPS_TRUST_PATH folder en el servidor, copie el contenido de /xoops_lib a esa carpeta, y elimine /xoops_lib de la carpeta "htdocs" de su ordenador LOCAL
   3. Subir el contenido de htdocs sobrescribiendo los archivos existentes
   4. Por razones de seguridad, le sugerimos que mueva la carpeta xoops_lib (la carpeta que contiene las bibliotecas de código para XOOPS) y xoops_data (para los datos de XOOPS) fuera de la raíz del sitio, o incluso cambiar los nombres de las carpetas.
   5. La carpeta xoops_data/ debe ser escribible; Crea y establezca permisos de escrituras a las siguientes carpetas: xoops_data/caches/, xoops_data/caches/xoops_cache/, xoops_data/caches/smarty_cache/ y xoops_data/caches/smarty_compile/
   6. Asegúrese de que el servidor pueda escribir a mainfile.php
   7. Si tenía ya Protector instalado previamente, abra el archivo "mainfile.php" y elimine las siguientes líneas (en caso de que existieran):
   
      include XOOPS_TRUST_PATH.'/modules/protector/include/precheck.inc.php' ;
      include XOOPS_TRUST_PATH.'/modules/protector/include/postcheck.inc.php' ;
   
   8. Acceder a <su.sitio.web>/upgrade/ con el navegador, y siga las instrucciones
   9. Seguir las instrucciones de actualización de la base de datos
   10. Proteja de nuevo contra escritura mainfile.php
  11. Elimine la carpeta upgrade una vez actualizado
  12. Actualice el módulo "sistema" desde el administrador de módulos


Actualizar desde cualquier versión de Xoops comprendida entre la 2.0.7 y la 2.0.13.2 (usando el paquete completo):
   0. Descomprima el archivo a su ordenador LOCAL (por ej. PC) en una carpeta temporal.
   1. Mueva la carpeta "upgrade" incluido en "htdocs" (se mantiene fuera porque no es necesario para las instalaciones nuevas)
   2. Eliminar htdocs/mainfile.php, htdocs/install/, htdocs/cache/, htdocs/extras/, htdocs/template_c/, htdocs/themes/ y htdocs/uploads/ de la carpeta "htdocs" de su ordenador LOCAL
      * si ha creado la carpeta XOOPS_TRUST_PATH folder en el servidor, copie el contenido de /xoops_lib a esa carpeta, y elimine /xoops_lib de la carpeta "htdocs" de su ordenador LOCAL
   3. Subir el contenido de htdocs sobrescribiendo los archivos existentes
   4. Eliminar las siguientes carpetas y archivos del servidor (pertenecen a versiones anteriores):
          * class/smarty/core
          * class/smarty/plugins/resource.db.php
   5. Asegúrese de que mainfile.php tiene permiso de escritura
   6. Si tenía ya Protector instalado previamente, abra el archivo "mainfile.php" y elimine las siguientes líneas (en caso de que existieran):
   
      include XOOPS_TRUST_PATH.'/modules/protector/include/precheck.inc.php' ;
      include XOOPS_TRUST_PATH.'/modules/protector/include/postcheck.inc.php' ;
   
   7. Por razones de seguridad, le sugerimos que mueva la carpeta xoops_lib (la carpeta que contiene las bibliotecas de código para XOOPS) y xoops_data (para los datos de XOOPS) fuera de la raíz del sitio, o incluso cambiar los nombres de las carpetas.
   8. La carpeta xoops_data/ debe ser escribible; Crea y establezca permisos de escrituras a las siguientes carpetas: xoops_data/caches/, xoops_data/caches/xoops_cache/, xoops_data/caches/smarty_cache/ y xoops_data/caches/smarty_compile/
   9. Acceder a /upgrade/ con el navegador y siga las instrucciones
   10. Proteja de nuevo contra escritura mainfile.php
  11. Elimine la carpeta upgrade una vez actualizado
  12. Actualice el módulo "sistema" desde el administrador de módulos. Los demás módulos también es recomendable actualizarlos.


Actualizar un sitio no UTF-8:
La codificación UTF-8 se ha introducido desde XOOPS 2.3 como juego de de caracteres predeterminado. Sin embargo, puede haber algunos problemas con la conversión de sitios web existentes no UTF-8 a sitios UTF-8.
Antes de que haya una buena solución para esta conversión, a raíz de la configuración, se recomienda al actualizar un sitio web existente si no eres un usuario experimentado:
 - Seleccione "No cambiar" en la opción de "Conjunto de caracteres y cotejamiento de la base de datos" en el proceso de actualización
 - Modificar /languages/yourlanguage/global.php para usar el valor de _CHARSET si este ha cambiado a UTF-8 en el archivo global.php como  [code]define('_CHARSET', 'UTF-8');[/code]


Actualizar paqute XoopsEditor:
Existen 6 editores WYSIWYG opcionalmente disponibles: FCKeditor, Koivi, NiceEdit, Wymeditor, Xinha, y Spaw2 que pueden ser instalados desde https://sourceforge.net/projects/xoops/files/XOOPS%20Editors/
Puesto que hay algunos cambios en la estructura de carpetas tanto en los editores fckeditor y tinymce, se recomienda eliminar los editores existentes antes de subirlos.
Y si está usando fckeditor para los módulos, por favor, modifique las siguientes configuraciones de módulos en /fckeditor/modules/, especialmente si utiliza el módulo "article (artículos)".


Nivel de información de depuración
-----------------------------------

Desde la versión XOOPS 2.3.1 el nivel de información de depuración está activa como una solución temporal en 2.3* para mostrar la depuración a distintos niveles de usuarios: a todos los usuarios, a miembros o sólo la administración.
La configuración puede ser editada en /xoops_data/configs/xoopsconfig.php
Un nuevo sistema de información de depuración está disponible desde la versión 2.4. mediante Firebug (see http://tinyurl.com/nmnjdp) 



Comprobación de integridad
-----------------------------------

El paquete completo de XOOPS es lanzado con un script capaz de comprobar la integridad del mismo una vez subido al servidor. Para usarlo haga lo siguiente:

   1. Suba checksum.php y checksum.md5 a la carpeta de XOOPS en el servidor (estarán por tanto junto a mainfile.php).
   2. Ejecute xoops_md5.php desde el navegador web
   3. Si fuera necesario, vuelva a subir el contenido perdido o corrupto
   4. Elimine xoops_md5.php y xoops.md5 del servidor


Módulos
-----------------------------------

Esta versión sólo contiene "módulos relacinados con el sistema". Le sugerimos consultar nuestro repositorio para encontrar los módulos adecuados. Nota: como un nuevo depósito se está construyendo, la actual no esta actualizada, POR FAVOR VISITAR LOS SITIOS WEB DE LOS DESARROLLADORES PARA ASEGURARSE DE QUE ESTÁ UTILIZANDO LA ÚLTIMA VERSIÓN DEL MÓDULO.


Cómo contribuir
-----------------------------------
Reportar bug: http://sourceforge.net/tracker/?group_id=41586&atid=430840
Parche y mejoras: http://sourceforge.net/tracker/?group_id=41586&atid=430842
Petición de características: http://sourceforge.net/tracker/?group_id=41586&atid=430843
Anuncio de publicaciones: https://lists.sourceforge.net/lists/listinfo/xoops-announcement


XOOPS Development Team
December 31, 2009
Return current item: XOOPS Spanish