Location: PHPKode > projects > PHPExplorer > install.php
<?

/**************************************
    PHP-Explore Install Script
***************************************/

if(!$go){ 
?><html>
<head>
  <title>Installation de PHP-Explorer</title>
</head>
<body bgcolor="white" text="#0F0F0F">
<table align="center" width="90%" border="2" bordercolor="#0F0F0F" cellspacing="0" cellpadding="2" bgcolor="#CCCCCC">
<tr><td align="center" width=100%>
<font style="color:black;font-size:25;align:center;">
<b>Installation de PHP-Explorer</b></font></td></tr></table><br>
<form method="POST" action="<?=$PHP_SELF?>">
<table align="center" width="90%" border="2" bordercolor="#0F0F0F" cellspacing="0" cellpadding="2" bgcolor="#CCCCCC">
<tr>
  <td><h1>Avant-Propos</h1>
<blockquote>
&nbsp; PHP-Explorer est une application Web écrite en PHP destinée à pouvoir administrer ses fichiers depuis un ordinateur 
distant aussi facilement voir plus que sur le poste en local.  Le seul prérequis est un serveur Web qui supporte le PHP.
<br><br>
 &nbsp; En plus, il est distribué gratuitement, mais sans aucunne garantie quand à son utilisation et aux dommages qu'il 
pourrait occasioner sur un ordinateur. Les sources fournies permettent aussi le développement d'add-ons, de plugins et 
d'apparences, qu'on peut aussi télécharger sur le site officiel.
</blockquote>
  </td>
</tr>
<tr>
  <td>
<h1>Installation</h1>
 &nbsp; &nbsp; Pour installer PHP-Explorer, vous devez entrer les informations suivantes :<br>
 &nbsp; &nbsp; <b><u>Si vous ne comprenez pas un des champs, référez vous au fichier lisezmoi.txt !!</b></u><br>
<blockquote>
<b>Mot de passe</b> <i>(ATTENTION : Ce mot de passe est très important, il permet l'accès à votre PC)</i><br>
<input type=password size=50 name=pwd><br><br>
<b>Confirmez le mot de passe :</b><br>
<input type=password size=50 name=pwd2><br><br>
<b>Paramètres de Super-Sécurité</b> <i>(Utilisateurs experts !)</i><br>
<i>La super-sécurité oblige à ce que l'on place le curseur de la souris à<br>
 un point donné de l'écran pour pouvoir s'authentifier (cf: <b>aide</b>)</i><br>
<input type="checkbox" name="use_supersec" value="1" id="usesec"> 
<label for="usesec">Activer la super-sécurité</label><br>
Position X : &nbsp; <input type="text" size="3" name="setx" value="100"> &nbsp;
  - &nbsp; Position Y : <input type="text" name="sety" value="420" size=3>
</blockquote>
<br><center><input type="submit" value=" Installer ! " style="width:150;" name="go"></center><br><br>
</td></tr><tr><td align=center><b>PHP-Explorer</b> a été créé par <b>Bouchon</b> pour <b>Max-Gamers.net</b></td></tr>
</table>
</form>
</body>
</html>
<?
}else{
$error="";
if($usesec&&($setx<0||$sety<0)) 
  $error.="Les valeurs pour la super-sécurité sont incorrectes !! ";
if(strlen($pwd)<6) $error.="Le mot de passe doit comprendre au moins 6 caractères !! ";
if($pwd!=$pwd2) $error.="Le mot de passe n\\'a pas été confirmé correctement !! ";
if($error) die("<html><Script>alert('$error');window.history.go(-1);</script>");
if($use_supersec) $tt="1"; else{ $tt="0"; $setx=0; $sety=0; }
$path=dirname($PHP_SELF); if($path!="/"&&$path!='\\') $path.="/";
$ip=dirname($_SERVER["PATH_TRANSLATED"]);
$f=fopen("include/config.php","w+"); fputs($f,"<?\r\n\$instp=\"$ip\";\r\n\$path=\"$path\";\r\n\$tmpd=\"C:\Windows\Temp\PHPE-Temp\";\r\n");
fputs($f,"\$skin_defaut=\"default\";\r\n\$supersecu=$tt;\r\n\$posx=$setx;\r\n\$posy=$sety;\r\n?>");
fclose($f); $f=fopen("include/psw.php","w+"); fputs($f,"<? \$bonpass=\"".base64_encode($pwd)."\"; ?>");fclose($f);
?><html>
<head>
  <title>Installation de PHP-Explorer</title>
</head>
<body bgcolor="white" text="#0F0F0F">
<table align="center" width="90%" border="2" bordercolor="#0F0F0F" cellspacing="0" cellpadding="2" bgcolor="#CCCCCC">
<tr><td align="center" width=100%>
<font style="color:black;font-size:25;align:center;">
<b>Installation de PHP-Explorer</b></font></td></tr></table><br>
<form method="POST" action="<?=$PHP_SELF?>">
<table align="center" width="90%" border="2" bordercolor="#0F0F0F" cellspacing="0" cellpadding="2" bgcolor="#CCCCCC">
<tr>
  <td><h1>L'installation de PHP-Explorer est terminée !</h1>
<blockquote>
 &nbsp; L'installation est terminée. Pour commencer à utiliser PHP-Explorer, rendez-vous <a href="<?=$path?>index.php">ICI</a>.
 Le script d'instrallation a été supprimé, pour modifier votre configuration vous devrez soit éditer le fichier config.php dans 
 le dossier "include/" ou cliquez sur le bouton "Changer les options" dans php-Explorer.<br><br>
 &nvqp; Si vous déplacez le dossier de php-Explorer, n'oubliez pas de modifier la configuration du script avant de déplacer !<br><br>
 &nbsp; Merci d'avoir choisi php-Explorer, et bonne utilisation !
</blockquote>
</td></tr></table>
</body></html>
<?
@unlink("./install.php");
die(); // Et voilà ..... oufff
}
?>
Return current item: PHPExplorer